Hello all and strange idle - Fiesta ST MK6 Discussion - Fiesta ST Owners Club

Jump to content

Hello all and strange idle


  • Please log in to reply
9 replies to this topic

#1
Waynewooly

Waynewooly
  • Forum User
  • 5 posts
Hi all, new to the forum so wanted to say hi first.

I have an odd idle issue when stopping or slowing down and wondered if anyone had any ideas?

I currently have the following setup;

Milltek manifold and high flow cat with a proflow backbox
60mm throttle body
ITG cold air induction
Cosworth copy manifold
Newman cams
8mm HT leads.

I have had the car in at Dreamscience for a Hyper R map and it is due back on Monday to check as its running a little rich.

I have changed the pcv valve and hose but the weird idle is irritating.

Any help would be gratefully received 🙏 😊

#2
jase_llan

jase_llan
  • Club Member
  • 1128 posts
@Waynewooly is it particularly bad when you have the clutch down and are rolling to a stop i.e. for traffic lights?

#3
Waynewooly

Waynewooly
  • Forum User
  • 5 posts
Hi Jase, thanks for your reply. Yeah it is, it only really happens then to be honest. It dips so low it almost stalls then picks up and is ok. Pressing the clutch doesn't make a differance if the car is stationary, its just the slowing to a halt when the issue appears.

Many thanks

#4
AMc

AMc

    'Mk7 Noob'

  • Club Staff
  • 23070 posts
Mk6s are known for this. They rev hunt if going to idle whilst still moving.

Need to keep it in gear until as late as possible really.

Could try taking the TB off and cleaning that up, helps a little, but it won't completely eradicate the issue.
  • jase_llan likes this

#5
Waynewooly

Waynewooly
  • Forum User
  • 5 posts
Hi there. Really appreciate the feedback, thankyou. Just seems a bit odd as the car has never done this before and it seems to have just started.....🤔 Randomly I get a p1132 code so its going back to the tuners tomorrow but currently the code is not present. All just a bit odd.

#6
Waynewooly

Waynewooly
  • Forum User
  • 5 posts
Hi all. Thanks for the feedback, car went to tuners yesterday and all was fine so it does look like something I'm gonna have to learn to live with.

On a plus....216bhp on the Dyno at Dreamscience 👍
  • ST3spin likes this

#7
Sethorion

Sethorion
  • Club Member
  • 75 posts

Ooooh, 216 is nice. Do you have any more details about your mods?

 

Also are you sure it was BHP and not HP?



#8
Waynewooly

Waynewooly
  • Forum User
  • 5 posts
Hi there, sorry for the delay....work for the NHS. So yeah its BHP, done the following;

Milltek headers with racing cat and proflow backbox
Cosworth copy inlet manifold
60mm throttle body
ITG cold air induction
Uprated HT leads
Newman Cams
Steeing resevoir relocate
35mm lowering springs
Hyper-R Remap at Dreamscience
ST180 alloys
Newly rebuilt mondeo calipers yet to go on*

Its goes like the clappers however I fear I may need to sell soon 🤨😐

#9
Adam-R

Adam-R
  • Club Member
  • 192 posts
  • sunderland
Mine is the same when dipping the clutch and rolling to a stop at the lights. You just learn not to dip your clutch early. Mine has always had an issue when starting. I have to give it a little bit throttle when starting it up. Dont have to do it every time but sometimes it will not start unless I press the accelerator. Never failed to start just havent had to do it in any other car. Had mine since 2008.
  • st150matt likes this

#10
st150matt

st150matt
  • Forum User
  • 1 posts
Im dealing with the same issue as you guys at the moment. Ive been through the following trying to identify the issue:

-PCV Valve and Hose
-Clutch pedal position sensor
-Coilpack
-Plugs
-Leads
-Thoroughly cleaned the throttle body and done the re-learn process TWICE.
-Checked all the vacuum lines I can find for leaks

Nothing has worked. Is it really something we have to live with? No mapping or update can help?

Crawling in traffic is a nightmare, lift the clutch up for a split second and dip it again and the revs shoot up for no reason. Driving me nuts!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users