Fiesta ST Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Hi guys and gals

Having a few few problems lately
Long story short my battery light came on and 10 minutes latter the car broke down (red screen)
The AA came took me to my local garage the problem turned out that I needed a new alternator.
However since being fixed 3 weeks ago the battery light keeps turning on and off. (the garage had a look at my car and Said they couldnt find a fault?
Also the indicators are starting to fail?

Any ideas what it could be?
Thanks for your time!
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 ·
What do you mean when you say the indicators are starting to fail? Do you have a multimeter handy?
Well every so often I'l push the indicator stalk and nothing happens. No indicator light to ticking or flashing on the dash. The battery light will come on and off every few minutes in a 20 mile journey For example today I drove 24 miles to work where the light came on and off every few minutes however on my way home it didn't come on once on my way home. Hope thats a bit more information

Nope don't have a multi tester but gonna check my fuses tomorrow.
 

·
Registered
Joined
·
2,598 Posts
Sounds like you need a new battery as well. It's not holding it's charge, but the fact that the light goes off after a while, shows that the alternator is charging it.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #7 ·
Nope don't have a multi tester but gonna check my fuses tomorrow.
If you could obtain a meter it would be very handy to check running voltage, battery voltage and possibly wire resistance if the voltage doesn't check out.
[/quote]

thanks for all the advice guys!

Couldn't get hold of a multi meter so took my car to another garage for a battery test. The results showed that the new alternator was producing to much power 15.6 volts? I was told this is why the battery light keeps turning on also the guy in the garage said this can start burning things and causing problems? Any chance this could be why my indicators are playing up? Either way gonna take the car back to the garage were the alternator was fitted n hopefully get it sorted!
 
1 - 7 of 7 Posts
Top