Fiesta ST Forums banner
1 - 20 of 31 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hey fellas, just bought myself a Mk7 fiesta but as usually after driving home I have some worries. Maybe you can put my mind to rest.

Two things:
1. There's rather a lot of vibration from the engine here's a vid:

Please note that on this video you can see only how far it vibrates and not how often, it just synced with shutter speed on my camera.

2. Oil seems to be overfilled. I checked it after it has been sat for an hour. it's filled to the red line
Electric blue Fashion accessory Pattern Science



Am I crazy or everything is normal?
 

·
Premium Member
Joined
·
2,387 Posts
One more video of the shake, maybe it's gonna be a bit clearer to see:

You can play it slower to see actual vibrations
When mine had stock engine mounts I can't remember seeing engine move like that, can you rock the engine back and forth easily by hand? if you can top right engine mount has gone.

re. oil level if it's more than about 5 millimetres over the max marker I'd be draining some out.
 

·
Registered
Joined
·
107 Posts
Even with engine mounts gone that seems like a lot of movement but it could be that maybe more than one has failed, perhaps the rear underside mount? I think the expansion tanks are quite loose on these cars, mine has the same movement as you've shown in the video.

I find that ford overfill my oil during servicing and I check before I drive away. Twice in a row I've had to get them to correct it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #11 ·
don't worrry about the radiator , mine is exactly the same clicky clicky

i even tried changing the radiator mounting bushes HERE

and radiator support bracket HERE

neither of which made a difference

That's something that I would not expect, will keep it as it is then.


But I've got a small update about this vibration, upon reading codes on my OBDII scanner I get a code P2187 running lean on bank 1. Maybe this would help diagnose it.
 

·
Registered
Joined
·
2,507 Posts
That's something that I would not expect, will keep it as it is then.


But I've got a small update about this vibration, upon reading codes on my OBDII scanner I get a code P2187 running lean on bank 1. Maybe this would help diagnose it.
Where did you buy it from?

If it was from a dealer, take it straight back. You shouldn't be seeing lean codes on a new to you car.
 

·
Registered
2014 Mk7 ST-3
Joined
·
194 Posts
How long do you have it?

Was any warranty given with it?
Normally over here it's 3 months gearbox and engine warranty from a used car dealer, not sure if it's the same there.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #15 ·
There's no warranty and I just bought it today. Would it be reasonable to allow a ford service department have a look at it and then consider taking further steps? It is in good nick all in all, and It can turn out to be just loose pipe somewhere.

How long do you have it?

Was any warranty given with it?
Normally over here it's 3 months gearbox and engine warranty from a used car dealer, not sure if it's the same there.
 

·
Super Moderator
Joined
·
24,125 Posts
Of course you can take it back, consumer rights act. Get them to rectify it, FOC or you'll hand it back and get a full refund.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #17 ·
I've left it with ford today, depending on what they say I'll be thinking about my next steps. I'll update when I'll know anything more
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #18 ·
Just got into that it's ready to collect, and service department didn't found anything out of ordinary with it. I'll have a word with tech that worked on it tomorrow and explain my concerns.
 

·
Registered
Joined
·
1,533 Posts
They didnt didnt anything wrong with an engine wobbling around like that? Im amazed that they manage to find their own mouths when they are eating if they are missing that. Why i do my own servicing. The engine shouldnt be doing that , not normal. On the plus side it does sound normal from the video, doesnt sound to be missing or idling poorly so as everyone else has stated it looks like the engine mounts maybe cream crackered.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #20 ·
They didnt didnt anything wrong with an engine wobbling around like that? Im amazed that they manage to find their own mouths when they are eating if they are missing that. Why i do my own servicing. The engine shouldnt be doing that , not normal. On the plus side it does sound normal from the video, doesnt sound to be missing or idling poorly so as everyone else has stated it looks like the engine mounts maybe cream crackered.
Having look through the papers they uploaded online there's a mention of mountune torque restrictor. I believe that's the upgraded bottom motor mount, maybe the top one gave up then. I really need to learn a lot more about this little cars
 
1 - 20 of 31 Posts
Top