Fiesta ST Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
4,697 Posts
Discussion Starter · #1 ·
Hi all

today I approached a set of traffic lights, dipped my clutch and the cars revs dropped right down to the point of cutting out. Why is this and is there a solution?

Cheers

Dave
 

·
Registered
Joined
·
1,562 Posts
Hi all

today I approached a set of traffic lights, dipped my clutch and the cars revs dropped right down to the point of cutting out. Why is this and is there a solution?

Cheers

Dave
Erm... it 's happend to me once or twice, but generally only within the first 5mins after start up, when the engines still warming up. What T/B you got?
 

·
Registered
Joined
·
4,697 Posts
Discussion Starter · #4 ·
I have the normal TB that comes standard. I was thinking maybe it's the alternator? To be fair it did happen quite early on after I had started driving...
 

·
Registered
Joined
·
1,562 Posts
I let mine idle for about 5 mins in a morning, and its fine on the way to work. I come out of work in the evening, and theres a set of lights about 200yds down the road - it's only when i pull up to these virtually straight after starting, that it acts up a bit. Fine after.
 

·
Registered
Joined
·
4,697 Posts
Discussion Starter · #6 ·
Yeah I had exactly the same thing. Good to know that it's not just mine. Cheers Ricky
 

·
Registered
Joined
·
932 Posts
Si is right dave. My car also does this when coming to a stop. Seems to be better when the engine is fully warmed up.
 

·
Registered
Joined
·
4,513 Posts
Mine does it all the time,it cut out the other day!

It very rarely cuts out but it does the rev dropping a lot.

Don't bother me really,car spends most of it's life making boost lol.

Lee
 

·
Registered
Joined
·
1,177 Posts
mine used to do this when cold. Im thinking its due to the charger giving a little bit more resistance when cold, so effectively trying to stop the aux belt, and in turn the engine. Fine when warmed up though.

Mine used to idle just under 1k
 

·
Registered
Joined
·
251 Posts
Mines not supercharged but does the same since I've had the Cossie inlet put on, mapped by Jamsport as well. Mine does it when the engine is warmed up though.
 

·
Registered
Joined
·
4,697 Posts
Discussion Starter · #18 ·
Yeah when my heaters are on full blast it was really struggling to keep the revs up but again that was only after the engine was cold
 

·
Registered
Joined
·
4,513 Posts
Mine is fine with the heaters on...it's just if I pull away dodgy and dip the clutch it sorta wants to stall...plus when I'm rolling and dip the clutch it drops to say 500rpm before it idles fine.

Way to sort it,go flat out!LOL!

Lee
 
1 - 19 of 19 Posts
Top