Fiesta ST Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter · #1 ·
I have never really got anywhere with this damn thing but at least it shows my service record.
lt has only ever showed my fuel level and oil life over the last 2 years but is now not showing the oil life at all.
Where it did show oil life it now shows a car outline logo with dealer on it.
l have removed and then re added the vehicle but to no joy.
Any ideas welcomed.
 

·
Premium Member
Joined
·
290 Posts
Delete the app, delete car from Bluetooth. Re-add car and phone together, download app. Ensure Fordpass app permissions include location allowed all the time, that worked for me. Good luck - it can be a bit finickity at the best of times.
 

·
Premium Member
Joined
·
462 Posts
I too uninstalled and reinstalled @ZoSo

Not trying to teach the sucking of eggs here but the new layout means you have to click the 'vehicle' icon on the bottom of the home page to get up all the vehicle stats and the Seculialert feature that used to be on the old home page*.

Have a play, it should all be there 👍

*that might be down to me running two cars off the app, a 'one car' app might be different for all I know 🤷‍♂️
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #4 ·
I have already deleted from car Bluetooth and reconnected.
It doesn’t matter if l click on the vehicle icon at bottom of page or the picture of a car still only gives fuel level.
Right from day 1 it has never given me anything but fuel level and oil life nothing else never had vehicle stats or securialert or tyre pressures etc
 

·
Registered
Joined
·
243 Posts
It's odd I have never had any issues with the App, not that I think it all that great but always had fuel reports, tyre pressures, location etc. I was pleased to see the digital service updated also.
What version are you running? Also what phone are you using and it that software up to date?
mine is Version 3.29.0 GBR (iPhone 12pro Max)
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #7 ·
Yes it’s version 3.29.0.
My phone is relatively new Samsung A41 less than 6 months old.
No l don’t think the app is worth the bother but frustrating that it doesn’t work as it should.
 

·
Registered
Joined
·
243 Posts
Yes it’s version 3.29.0.
My phone is relatively new Samsung A41 less than 6 months old.
No l don’t think the app is worth the bother but frustrating that it doesn’t work as it should.
As the App is up to date and can work and your phone is up to date it's more likely there is some privacy/data sharing setting either on your phone or in the app settings? its probably deeply hidden somewhere!
 

·
Premium Member
Joined
·
462 Posts
Obviously if you don't see much point to the app then perhaps don't bother, but their technical team will eventually sort out any issues. They fixed my issue whereby the oil life stopped updating and was stuck on 45%, service details were also missing... turns out my old dealership were just 💩 at doing their paperwork/admin after services 🙄

It all works fine now but I was just like you @ZoSo I didn't bother chasing it up for the longest time until the principle that 'if it's supposed to work it should bloody well work' got the better of me.
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #10 ·
Thanks for the comments.
l can’t see anything in my phone app permissions and there is nothing to change on the ford pass icon or in settings on the sync 3 screen in the car.
Think l will pay my Ford dealer a visit as the guy who dealt with the sale seemed tech savvy(something l am definitely not)
 

·
Registered
Joined
·
243 Posts
Thanks for the comments.
l can’t see anything in my phone app permissions and there is nothing to change on the ford pass icon or in settings on the sync 3 screen in the car.
Think l will pay my Ford dealer a visit as the guy who dealt with the sale seemed tech savvy(something l am definitely not)
Yeah that sounds like a good idea! for tech stuff i ask my teenage daughter these days! 😂
 
1 - 11 of 11 Posts
Top