Fiesta ST Forums banner
21 - 37 of 37 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter · #21 ·
Good luck with that.

All I got back is that the rubber ring must be stretched and the'd send me a new one.

But I took it apart so was not stretched.

Didn't now there was another one without the spit in it!
 

·
Registered
Joined
·
292 Posts
Having fitted mine today using @DaHermit23 Only issue I'm seeing is that as the mount is rocking back and forth, the insert appears to be catching on the edge of the hole in the black part of the mount and deforming a little.
Fitted mine this afternoon and mine is doing exactly the same. The slice could do with being a bit bigger. I also left the engine mount on and just jacked the engine up to reveal a bit more of a gap. Wonder if this is the problem?
 

Attachments

·
Registered
Joined
·
1,347 Posts
Fitted mine this afternoon and mine is doing exactly the same. The slice could do with being a bit bigger. I also left the engine mount on and just jacked the engine up to reveal a bit more of a gap. Wonder if this is the problem?
Don't think so, the engine will move as soon as it's assembled and driven. Mine sank even further in after the first drive and has sort of settled into one spot now.

Kudos on the metal cable tie though, mines still one with two small ones joined together.
 

·
Registered
Joined
·
121 Posts
I had a quick response from Powerflex (James Bourn - Sale Director) and email conversation. He hadn't heard of the issue before with the insert slidding into the mount gap below. He couldn't suggest why this issue was occuring without looking and as I hadn't used any lubricants etc he was unsure. I mentioned that a few of us on this forum had been having issues and a product without the split had been provided to another customer. They are going to make me one without he split so I can try that. I know its not ideal as I will need to dismantle the mount and tighten without a spanner in the gap to counter the torque, but not much else I can do. I guess thats why they designed it with the split or maybe just for easy instal....
I will instal the new one when it arrives and the weather stops ******* with rain and blowing down trees.
 

·
Registered
Joined
·
1 Posts
The slice is normal its so it can be fitted while still on the car































































































































































































































































It's got a round centre because it sits in thent and tucks under the square bit as the original black rubber stays on top with the square bit
















































































































perfect















































Fitted mine and is perf















ect
 

·
Registered
Joined
·
392 Posts
I will be fitting this tomorrow, I've bought the thin spanner off amazon, mine has a slight split in the insert, the o ring is about 3/4 the size of the insert.

I spoke to powerflex at ford fair about the problem people been having and they have said the revised one is the one which is flat one side and the other side is shaped so it fits into the bottom of the engine mount better, not the pineapple one.
Mine does have a slight split in it, if I have any problems I'll post up here, should be interesting to see what difference it makes if any, also have the transmission side too.
 

·
Registered
Joined
·
392 Posts
OK so I thought I'd do a follow up on this, took around 2hr 30min to fit both but that was just due to me taking my time and not rushing.

That spanner that people where on about did help but for only like 5 sec and I only used it once, gearbox was straight forward, when fitting it back it wasn't 100% where it was before as the polybush was hitting against the body of the car, litterally only 1 or 2mm out if that.

Driverside one was dead easy too, I dismantled it all so I didn't have to stretch that little black band around the top plate :S I think it's called like in the instructions told me to, I litterally took it apart put the wedge in and it fitted snuggly, the bottom shape filled the gap on the oem mount then I put the band around it, its not going anywhere! Put it all back together.

Visually the engine has raised up slightly due to it taking all the slack from the oem mounts.

On start up I was expecting alot of vibration but honestly hardly anything!! I have vibration on start up, Aircon on and when I'm driving just over the 2k rpm.
When driving my middle mirror does vibrate alil.

It has transformed the car!!!! Its so damn solid!
First drive was on the way to work which has alot of speed bumps, big ones and sharp ones, before I could feel the engine rocking when I went over them that's completely gone.

Next drive was on the twistys where I fly my drone and its so responsive, rev matching is alot easier and more precise. Turning into corners is better, tighter.

Last ride on the night was motorway driving, where I didn't think any difference would be, how wrong I was, still that rapid responsiveness instead of waiting alil, the power is just there.

Feels like a new car, such a massive difference in both day to day driving and when you wanna have fun. Honestly believe it's fractionally improved my 0-60 and after a weeks driving it, the wedge people go on about hasn't moved or slipped.

The only way I can describe it is I test drove the cupra born which is electric and as soon as you put your foot down in the born it just went and this is exactly like driving my ST now! It's just instant! No delay. I love it!
 

·
Registered
Joined
·
392 Posts
Have you changed the rear motor mount aswell? And if so which one did you go for? Cheers
Hi yeah I changed that one first tbh, it's with purple bushes so I think that one Is fast road/track use, everyone seems to go for the softer yellow bushes but from matt Lewis said the difference isn't too much, I like it, makes you feel more part of the car, well worth the upgrade, wish I had done it sooner!
 
21 - 37 of 37 Posts
Top