Fiesta ST Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hi all wonder if any one can help my st 05 is running ruff if you are in a low gear and put foot down at low speed it seems to miss i.e. like thears no fuel or no spark! lift the clutch and revs sweet but under load plays up ive changed fuel filter replaced plugs done oil and filter change just the same! also when takeing foot off throttle when comeing to a stop ect. revs dropp to 6 - 700 rpms please help cheers rick
 

·
Registered
Joined
·
4,513 Posts
Try HT leads,or try to update your ecu...that may help..

Just give the car a once over and make sure things are ok..try the obove it may help..

The ecu update you can get through ford..

Lee
 

·
Registered
Joined
·
3,941 Posts
Spark plugs
HT leads
Coilpack

would be what id check first.

is it ok once it heats up or is it always doing it? Any mods done to car?

I got some spare sparks, HT leads and a coil we could test with.... where in the SE are you?
 

·
Registered
Joined
·
4,513 Posts
can't be nothing big..

Coilpacks go so Adam you could have hit the nail on the head!

There's loads of 05 ST's with issues ATM..must be time of the month for them!

Lol
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
seems wors when its warmed up!
Spark plugs
HT leads
Coilpack

would be what id check first.

is it ok once it heats up or is it always doing it? Any mods done to car?

I got some spare sparks, HT leads and a coil we could test with.... where in the SE are you?
 
1 - 11 of 11 Posts
Top